The Web Validator is compatible with the following internet browsers:

  1. Google Chrome
  2. Internet Explorer 11 or newer
  3. Microsoft Edge


If you are experiencing issues with the validation tools, please confirm that you have one of the browser versions listed above. If you still are experiencing an issue, please contact support@premiumparking.comĀ